01 July 2007

Upcoming API Changes

I've started cleaning up the APIs a bit, revising stuff that doesn't feel quite right in actual use. The biggest change is in method naming conventions. For some reason, it originally felt like a good idea to capitalize class methods and methods on singleton objects differently (using CapWords), but this hasn't really felt Pythonic when using the framework, so I'm going to change everything to lowercase_words now that I still can. The old naming convention will still work in alpha 6, but it prints out a deprecation warning as a reminder.

Other changes that I'm currently evaluating include moving sprite rect attributes to the sprite object itself, so that you use e.g. sprite.left instead of sprite.rect.left and so on. The particle emitter API is another part that feels somehow off, so expect at least small changes there.

I'm trying to get all backward incompatible changes out of the way by alpha 7, so that APIs in alpha 8 and onwards should stay stable and compatible.

0 Comments:

Post a Comment

<< Home